The incident has been resolved. The fix has been successfully deployed to all production systems, and normal operation has been fully restored.
Posted Oct 28, 2025 - 17:02 CET
Update
We have developed a fix addressing the Control Plane health logic issue. The update is currently being tested and validated in our development and staging environments to ensure stability before production release.
We’ve also completed triage of all Enterprise clusters to ensure the issue is not affecting the interactions in our SaaS Console.
Posted Oct 28, 2025 - 14:28 CET
Identified
We’ve identified an issue with the health evaluation logic in our Control Plane and are actively working on a fix.
In the meantime, we’re manually triaging affected clusters to move them out of the “Update” state.
The Camunda cluster itself is available and not affected from this.
Posted Oct 28, 2025 - 13:51 CET
Investigating
We are currently investigating alerts of stuck updates. The health information in our SaaS Console calculates that the update process is ongoing. However, the update is already finished.
We identified that the health logic incorrectly takes into account the legacy importer from the prior version.
Impact: Incorrect health states in our SaaS Console and issues by dependent systems that take the health state into account.
Affected Versions: Clusters that were updated to SaaS Generation 8.8gen2