Critical bug on Camunda 8.2.22 and 8.1.23
Incident Report for Camunda Platform 8 SaaS
Resolved
All clusters which have been running the Generations suffering from the critical bug camunda/zeebe#16406 have been updated to one of two emergency Generations `Camunda 8.2.22 with Zeebe 8.2.23` or `Camunda 8.1.23 with Zeebe 8.1.24`. These are not endangered to run into this issue anymore.

An all component 8.2.23 and 8.1.24 Generation will be released early next week and update paths enabled from existing 8.2.x and 8.2.x Generations.
Posted Feb 16, 2024 - 19:12 CET
Update
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Feb 16, 2024 - 16:44 CET
Identified
Camunda versions 8.2.22 and 8.1.23 suffer from a critical bug camunda/zeebe#16406 that can result in a Zeebe broker being unable to start if at least one DMN Model is deployed. We have disabled the update path to those Generations as well as removed them from the stable channel.

Some clusters are already running those Generations. An emergency Generation to be released soon and we will update those clusters once the emergency Generation is live. We plan to release a GA Generation containing the 8.2.23 and 8.1.24 releases of all components at beginning next week.
Posted Feb 16, 2024 - 16:42 CET
This incident affected: Zeebe.