Connectors 8.8 issues after upgrades with Early Access feature are experiencing issues.

Incident Report for Camunda Platform 8 SaaS

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 19:30 CET

Monitoring

We are in the process of rolling out the configuration fix across our fleet of clusters. The rollout is being performed gradually. We are closely monitoring all environments as the update progresses.
Posted Oct 30, 2025 - 19:24 CET

Identified

Camunda Clusters running version 8.8 with app-integrations enabled are currently experiencing a service disruption affecting Connectors; when using this early access alpha feature.

We’ve identified the root cause as a malformed configuration introduced in this version. A software fix has been developed and is currently undergoing testing in our integration environments.
Posted Oct 30, 2025 - 18:25 CET

Investigating

We are currently investigating issues with Connectors after an upgrade to 8.8. Our team is working to identify the cause and implement a solution.
Posted Oct 30, 2025 - 17:54 CET