Web Modeler performance degradation

Incident Report for Camunda Platform 8 SaaS

Resolved

A hotfix was deployed to mitigate the issue.

We apologize for any inconvenience caused and thank you for your patience.
Posted Aug 08, 2026 - 23:57 CEST

Update

We are continuing to work on a fix for this issue.
Posted Aug 08, 2026 - 23:00 CEST

Identified

The issue has been identified as caused by database lock contention from the background cleanup of recently deleted items. We are working to mitigate the issue.
Posted Aug 08, 2026 - 22:45 CEST

Investigating

We are currently investigating reports of degraded performance of Camunda's Web Modeler offering. Our team is working to identify the cause and implement a solution.
Posted Aug 08, 2026 - 22:00 CEST
This incident affected: Modeler.