We apologize for any inconvenience caused and thank you for your patience.
Posted May 08, 2026 - 11:43 CEST
Update
We are continuing to monitor for any further issues.
Posted May 08, 2026 - 11:41 CEST
Monitoring
We continue to monitor the ongoing AWS infrastructure issue affecting one Availability Zone in the US-EAST-1 region. AWS reports continued progress toward recovery, with most affected hardware already restored. A small number of resources may still see elevated error rates or latency until AWS completes full recovery.
Most customer workloads have returned to normal operation. We are actively restoring the few remaining impacted services and will share another update once AWS provides their next status report (expected by 12:00 CEST).
Posted May 08, 2026 - 09:06 CEST
Identified
The issue has been identified as AWS incident in availability zone use1-az4/us-east-1b. We are working to mitigate the issue and will provide an update in the next 2hrs.
Affected Region: AWS - US-EAST-1
Summary of AWS incident - https://health.aws.amazon.com/health/status AWS is currently experiencing an infrastructure issue in one Availability Zone of the US-EAST-1 region, caused by elevated temperatures in a single data center. As a result, some compute and storage resources in that zone are operating with reduced availability or increased latency. Other zones in US-EAST-1 are unaffected.
AWS reports early signs of recovery: additional cooling capacity has been brought online and affected hardware is being restored in a controlled manner. Some workloads in the impacted zone may continue to see elevated error rates until full recovery is complete.
We are actively monitoring the situation and will share further updates as the situation evolves.